How do I keep my system up to date? =================================== The ports collection (FreeBSD's package management system) is installed into /usr/ports by ServePath. The first thing to do is to make sure that the latest patch sets have been installed. # cd /usr/ports # cd sysutils/portmanager && make all install && cd /usr/ports # cd sysutils/portsnap && make all install && cd /usr/local/etc # mv portsnap.conf.sample portsnap.conf && cd /usr/local/sbin # ./portsnap fetch && ./portsnap extract The above commands will install two programs, portmanager, and portsnap. These programs update the installed applications and uninstalled sources, respectively. These two programs work together in keeping FreeBSD up to date. In order to apply the updated patch sets, execute the below: # /usr/local/sbin/portsnap fetch # /usr/local/sbin/portsnap update In order to upgrade the installed applications, execute: # /usr/local/sbin/portmanager -u sound ===== kldload snd_*** adding the appropriate line to the file /boot/loader.conf pkg_add ======= set where packages are fetched from: in bash: #export PACKAGESITE=ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages/Latest/ in zsh: #export PACKAGESITE=ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages/Latest/ Then do #pkg_add -r packagename to install keyboard ======== To make keys work properly in bash: Make a .bashrc with this line: export INPUTRC=~/.inputrc Then make a .inputrc with these lines: set meta-flag on set output-meta on set convert-meta off "\e[1~": beginning-of-line "\e[2~": yank "\e[3~": delete-char "\e[4~": end-of-line "\e[C": forward-char "\e[D": backward-char "\e[A": previous-history "\e[B": next-history "\C-?": delete-char "\C-H": backward-delete-char "\e[1~": beginning-of-line "\e[4~": end-of-line freebsd printing =============== http://forums.bsdnexus.com/viewtopic.php?id=36 freebsd-update ============= binary updates to freebsd base # cd /usr/ports/security/freebsd-update # make install clean # cp /usr/local/etc/freebsd-update.conf.sample /usr/local/etc/freebsd-update.conf # /usr/local/sbin/freebsd-update fetch # /usr/local/sbin/freebsd-update install QUOTE: In order to provide an easy update path for i386 systems from | | FreeBSD 5.2 to FreeBSD 5.2.1, FreeBSD Update will now update | | systems running FreeBSD 5.2-RELEASE to 5.2.1-RELEASE. To take | | advantage of these updates, install and run FreeBSD Update, and | | reboot into the new kernel: | | | | # cd /usr/ports/security/freebsd-update && make install clean | | # cp /usr/local/etc/freebsd-update.conf.sample | | /usr/local/etc/freebsd-update.conf | | # /usr/local/sbin/freebsd-update fetch | | # /usr/local/sbin/freebsd-update install | | # shutdown -r now | | | | If you have recompiled any files locally, FreeBSD Update may | | not be able to update them automatically (it will complain). | | With the latest version of FreeBSD Update (version 1.5), you | | can use one of the following commands: | | # /usr/local/sbin/freebsd-update --branch crypto fetch | | or | | # /usr/local/sbin/freebsd-update --branch nocrypto fetch | | depending upon whether you installed the "crypto" distribution, | | to force files to be updated. (If you're not sure if you | | installed the "crypto" distribution, you almost certainly did). | | | | FreeBSD Update will update a 5.2-RELEASE system to the exact | | binaries distributed with 5.2.1-RELEASE, with the following | | exceptions: | | | | 1. Files under the following directories will not be updated: | | | | /usr/ports | | /usr/share/doc | | /usr/share/man/cat* | | /usr/src | | | | The ports and src trees can be updated using cvsup; the files | | in /usr/share/man/cat* are rebuilt from (updated) man pages | | automatically. | | | | 2. FreeBSD binaries include, in their headers, the value of | | __FreeBSD_version on the machine where they were compiled. | | This value was bumped from 502000 to 502010 as part of the | | release engineering process; binaries for which this is the | | ONLY change will not be updated. | | | | As always, this is something I'm providing personally; it is | | in no way endorsed by the Security Officer, Release Engineering | | team, or the project as a whole. Upgrading binary packages ========================== Upgrading using ports or packages is fairly simple for me. I mainly use binary method "pkg_add -r" if you want to use the latest version you might not be able to find it in the default RELEASE mirror. Try and change the value of the variable PACKAGESITE to STABLE: setenv PACKAGESITE ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-6-stable/Lat... Because packages-*-release directories are built from the ports collection shipped with the release, and are not updated. But packages-*-stable and packages-*-current are updated roughly once a week. If you want to make this the default site then take a look at /usr/local/etc/pkgtools.conf If you do not want to check everytime that the binary package exists for the latest version or not then use portupgrade and pass the -P parameter. The procedure weekly is like this: 1- I upgrade my port tree using portsnap: portsnap fetch portsnap update 2- then I update ports db and check if my installed packages and ports are older than the new port tree: portversion -v -l"<" 3- if there is anything to upgrade i make sure that PACKAGESITE is using STABLE instead of RELEASE then i run portupgrade: portupgrade -vaRrPp Look at the man page if you want to know what the other parameters do. If you are worried about breaking software you should always check /usr/ports/UPDATING This is really quick procedure and most of the time portupgrade uses the binary package to update and it works just fine. if the binary package is not there it will just build it from the port. Gotta Love FreeBSD Make World ========== So, yesterday, I realized that I needed to make a change to my kernel and so I made my changes to it and then went to run /usr/sbin/config on it and the system told me that my version of config did not match my source tree. This is correct. For some time now I have been running CVS to keep both my ports and source trees current. The only problem is, I had no idea what to do with it once I had things current. With the sources, you can perform something called a Makeworld as follows to upgrade your entire operating system. 1. Reboot your computer to single user mode. 2. Run an fsck -y 3. Run mount -u 4. Run mount -a 5. Load your swap partition by typing swapon -a 6. Now, go to your /usr/src directory and run a make buildworld to compile all of your sources. This does not actually install anything. If you want to run this as multi-threaded as FreeBSD recommends, then run this command instead make -j4 buildworld 7. After several hours of compiling, you can then install the sources by running make installworld 8. Now, you need to rebuild your kernel using the new sources. Run a make buildkernel from the /usr/src directory. This will be the GENERIC kernel. 9. To install your new kernel, run make installkernel 10. Run mergemaster to clean up all of the files in the /etc/ directory. This is an automated manual process, so be prepared to do a lot of confirming of changes. 11. Go to the /dev/ directory and rebuild all of your devices by running sh MAKEDEV all 12. To rebuild sysinstall go to /usr/src/release/sysinstall and run make all install. (If you ever need to upgrade a small part of your source, you can use this same process here just going to the appropriate directory.) 13. Run fastboot to reboot. 14. After booting, you should come up with your new GENERIC kernel and by running a uname -a, you should see the new version of your OS is installed. [tethys]:[12:07pm]:[/home/rnejdl] > uname -a FreeBSD tethys.ringofsaturn.com 4.5-STABLE FreeBSD 4.5-STABLE #0: Sat Feb 16 23:15:16 CST 2002 root@tethys.ringofsaturn.com:/usr/src/sys/compile/SATURN i386 [tethys]:[12:07pm]:[/home/rnejdl] > 15. At this point, you can delete the /usr/obj directory to clean up some space and you will have to do this anyways if you want to upgrade your sources again. 16. To rebuild your kernel, you can follow the normal process. However, I had to delete all of the /usr/src/sys/compile/KERNELNAME directory before my kernel would compile correctly, so you should probably delete this before rebuilding your new kernel. That may look like quite a few steps but this is a pretty straight forward process but the process is fairly forgiving. I screwed up several steps here because I didn't read the directions and I still was able to successfully complete the entire process. ============================================= The FreeBSD Ports Collection - Staying Current BSD | HOWTO Submitted by sherin on Sun, 2004-06-13 00:03. The ports collection makes life easier, you can go about doing make, make install without knowing much about anything else. The ports collection is growing bigger, new ports being added on a daily basis. Using CVSup, one of the utilities in the ports collection you can stay current with the ports collection and even update your source directory tree /src. Installing CVSup Do these as root only, #cd /usr/ports/net/cvsup #make install clean After you login back, as root copy /usr/share/examples/ports-supfile to /root directory (for obvious reasons) #cp /usr/share/example/ports-supfile /root/ports-supfile Now we need to do some editing, fire up your favourite editor, mine being emacs, #emacs /root/ports-supfile It should look something like this, ####################################################### *default host=cvsup.cn.FreeBSD.org. *default base=/usr *default prefix=/usr *default release=cvs tag=. *default delete use-rel-suffix #comment the below line if you don't want to update the /src directory src-all #update /usr/ports ports-all tag=. ####################################################### In the first line that I edited, I chose a host nearer to India --> China (cn). Alternatively you can choose your host from here Moment of truth has arrived, as root run #cvsup -L 2 /root/ports-supfile This command upgrades all the skeletons of the ports collection. To understand what the switches stand for and more information on cvsup refer tto the manual pages, #man cvsup Updating the ports database After completing each CVSup run, #portsdb -Uu An INDEX.db database is created or updated, in /usr/ports. After you get the prompt back, # Portupgrade If there is any output we need to upgrade those ports. All the ports can be collectively upgraded using the recursive switches, #portupgrade -arR It\'s important we upgrade the dependencies of the ports also so that we do not end up with a port which refuses to upgrade. When I did this i got a message asking me to do portdb -F . This utility updates the package database located at /var/db/pkg/pkgdb.db #pkgdb -F Running the above command interactively fixes the database.Do not interrupt this at any cost or you could end up with an inconsistent database. In case of a mess use, #pkgdb -fu Above command, fixes everything non interactively with what it thinks to be the best option. Summary 1. Use CVSup to sync the ports collection. 2. Portsdb to update the database INDEX.db. 3. Portversion to find which all ports need upgrading. 4. Finally portupgrade to upgrade those ports. 5. Pkgdb (do it when explicitly asked for) to update the package database. Now let me leave, I got some updated ports to install ;-). Happy holidays. fastest_cvsup http://fastest-cvsup.sourceforge.net/ samba shares automounting http://sig9.com/articles/samba-automount-freebsd freebsd update http://www.lugatgt.org/articles/freebsd_update/ freebsd5 http://home.nyc.rr.com/computertaijutsu/FreeBSD5x.html